What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Network Issues
Incident Report for Brandeis University
Resolved
Network issues resolved, there may be residual systems issues.
Posted Nov 28, 2016 - 10:44 EST
Investigating
NetSys is looking into network connectivity issues
Posted Nov 28, 2016 - 09:36 EST