What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Comcast Analog Cable TV Outage
Incident Report for Brandeis University
Resolved
Comcast resolved the issue with the local nodes.
Posted Nov 30, 2016 - 18:39 EST
Monitoring
Comcast has identified the issue and they are working to resolve. Service may be intermittent.
Posted Nov 30, 2016 - 15:25 EST
Investigating
Comcast Analog TV is currently down. Digitial service (IPTV) is still up and operational.

Comcast is currently investigating.
Posted Nov 30, 2016 - 14:31 EST