What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Ensemble Video server: Videos not playing
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Mar 14, 2018 - 13:50 EDT
Investigating
Videos are currently not playing back on the Ensemble Video system. We are investigating the issue.
Posted Mar 14, 2018 - 11:51 EDT
This incident affected: Brandeis Websites and Applications.