What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Rosenstiel Connectivity
Incident Report for Brandeis University
Resolved
A UPS power issue within the Rosenstiel Building has been resolved and all network connectivity has been restored.
Posted Mar 13, 2018 - 16:17 EDT
Investigating
We are currently investigating the loss of network connectivity in the Rosenstiel Building. We will continue to provide updates as information becomes available.
Posted Mar 13, 2018 - 13:22 EDT
This incident affected: Network/Internet.