What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

R25 issues
Incident Report for Brandeis University
Resolved
All issues related to R25 and 25live have been resolved.
Posted Jan 22, 2018 - 11:19 EST
Update
R25 is still experiencing issues with reports, ITS is investigating
Posted Jan 17, 2018 - 17:17 EST
Identified
Applications has identified issues with the R25 application this morning. Please use 25live while the R25 issues are being resolved.
Posted Jan 17, 2018 - 10:45 EST