What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

identity.brandeis.edu down
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Oct 25, 2016 - 14:27 EDT
Investigating
The Brandeis UNet Account Tools website (Identity Management) is currently down due to internal network instability.

Thank you for your patience.
Posted Oct 25, 2016 - 12:58 EDT