What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Admin printing (Papercut) - Intermittent Issues
Incident Report for Brandeis University
Resolved
ITS has resolved the issue affecting admin printing. Users can resume printing as need. If you encounter any issues, please contact the Help Desk (help@brandeis.edu or 781-736-4357).
Posted Jul 21, 2020 - 14:14 EDT
Monitoring
ITS has resolved the issue affecting admin printing. Faculty and staff can continue to send print jobs as needed; if jobs did not print as expected, they may need to be resent. If you encounter any issues, please contact the Help Desk (help@brandeis.edu or 781-736-4357). Thank you for your patience.
Posted Jul 21, 2020 - 12:25 EDT
Investigating
ITS is investigating intermittent issues with campus printing (Papercut). This issue specifically affects administrative print jobs; users will encounter an error message when accessing the print job on campus printers. Users can continue to use local functions such as scan and copy. Updates will be posted as they become available. We apologize for the inconvenience.
Posted Jul 21, 2020 - 12:09 EDT
This incident affected: Other Systems/Services (Campus printing (Papercut)).