What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Mailing list service (lists.brandeis.edu) - Service Disruption
Incident Report for Brandeis University
Resolved
ITS has resolved the issue with the university mailing list service (lists.brandeis.edu). If you encounter any issues sending and/or receiving messages from lists.brandeis.edu, please contact the Help Desk (6-4357 or help@brandeis.edu).
Posted May 10, 2019 - 13:15 EDT
Monitoring
ITS has addressed the issue with the Mailing Lists service (lists.brandeis.edu) and will continue to monitor to ensure service is fully restored. If you encounter any issues sending and/or receiving messages from lists.brandeis.edu, please contact the Help Desk (6-4357 or help@brandeis.edu).
Posted May 10, 2019 - 11:14 EDT
Investigating
ITS is aware there is an interruption in the delivery of email using the mailing lists service (lists.brandeis.edu). The issue is currently being investigated and updates will be provided as they become available.
Posted May 10, 2019 - 08:16 EDT