What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Inbound Phone Service
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Nov 17, 2018 - 12:04 EST
Update
ITS continues to monitor the voice circuits. We have had no further incidents to date. Additional maintenance may still be required at a future date.
Posted Nov 16, 2018 - 08:17 EST
Monitoring
Inbound calling into campus has been restored. ITS will continue to monitor. Further maintenance may still be required at a future date.
Posted Nov 14, 2018 - 19:38 EST
Investigating
We are currently investigating an issue in which inbound calls to Brandeis are not being completed. Outbound calls from Brandeis do not appear to be affected at this time.
Posted Nov 14, 2018 - 16:11 EST
This incident affected: Phone System.