What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Duo 2-Factor Latency
Incident Report for Brandeis University
Resolved
According to Duo, the issue is resolved: https://status.duo.com/. Please contact help@brandeis.edu if you continue to experience difficulty with Duo 2-factor.
Posted about 1 month ago. Jan 10, 2019 - 17:40 EST
Investigating
Duo 2-factor authentication is experiencing latency per https://status.duo.com. Users may experience delays authenticating to Brandeis applications. ITS is continuing to monitor the situation.
Posted about 1 month ago. Jan 10, 2019 - 16:24 EST
This incident affected: Authentication and Login (Authentication/Login).