What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Duo Two-factor Authentication - Intermittent Issues
Incident Report for Brandeis University
Resolved
Duo has reported the issue has been resolved. If you continue to have issues using Duo two-factor authentication, please contact the Help Desk (6-HELP or help@brandeis.edu).
Posted Jun 24, 2019 - 09:51 EDT
Investigating
ITS is aware there is an issue with Duo two-factor authentication. Duo is currently investigating reports that some customers are unable to access Duo or other AWS hosted services. AWS has confirmed an issue with an external provider outside of their network. Duo is closely tracking the issue to assess and minimize impact to Duo customers.
Posted Jun 24, 2019 - 09:17 EDT
This incident affected: Authentication and Login (Authentication/Login).