What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Internet Connectivity Issues/Phones
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 15, 2019 - 13:01 EST
Investigating
We are currently getting reports of various networks on campus not giving out IP addresses and phones not registering. ITS is looking into the issues and will update information as we receive it.
Posted 3 months ago. Jan 14, 2019 - 11:40 EST
This incident affected: Network/Internet and Phone System.