What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Sage - Service Disruption
Incident Report for Brandeis University
Resolved
ITS has confirmed the previously reported issue regarding access to Sage has been resolved. If you encounter any issues accessing Sage or other campus services, please contact the Help Desk (help@brandeis.edu or 781-736-4357). Thank you for your patience.
Posted Jul 26, 2021 - 09:06 EDT
Monitoring
As of 12 p.m. EDT, ITS has restored access and service to Sage. The team will continue to monitor the system to ensure it remains available and accessible to the community. If you're having issues accessing Sage or other campus systems, please email help@brandeis.edu. Thank you for your patience.
Posted Jul 25, 2021 - 12:12 EDT
Investigating
ITS is aware that Sage is currently unavailable. The team is actively working on restoring service. Updates will be posted as they become available. If you're encountering issues accessing other campus systems or services, please email help@brandeis.edu. We apologize for the inconvenience.
Posted Jul 25, 2021 - 10:43 EDT
This incident affected: ERP (Workday, sage, Finance, Data Warehouse).