What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Zoom Phone Services - Service Disruption
Incident Report for Brandeis University
Resolved
Zoom has implemented a fix to address the previously reported issue making and receiving calls through the Zoom Telephone services. The team will continue to monitor the service to ensure it is working as expected.
Posted Mar 17, 2020 - 15:36 EDT
Investigating
Zoom has received reports of issues making and receiving calls through the Zoom Telephone services (specifically in U.S. zones). Their team is actively working on resolving the issue. Updates will be posted as they become available. Thank you for your patience.
Posted Mar 17, 2020 - 12:29 EDT
This incident affected: Collaboration and Sharing (Zoom Telephone Services).