What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Duo (two-factor authentication) - Phone Call Delivery Issues to Chinese Numbers
Incident Report for Brandeis University
Resolved
Duo has confirmed that the previously reported issue with phone callback delivery to Chinese phone numbers is fully resolved and all services are now fully functional. If you encounter any issues with Duo two-factor authentication, please contact the Help Desk (help@brandeis.edu or 781-736-4357).
Posted Apr 07, 2021 - 08:06 EDT
Monitoring
Duo has implemented a fix to address the previously reported issue of phone call delivery issues to Chinese phone numbers. If you encounter any issues with Duo authentication, please contact the Help Desk (help@brandeis.edu or 781-736-4357). Thank you for your patience.
Posted Apr 06, 2021 - 12:37 EDT
Identified
Duo has identified there is an issue causing phone delivery issues to Chinese numbers and the Duo team is working to correct the issue as soon as possible. Where possible, use alternative authentication methods, such as push or SMS. Updates will be posted as they become available.
Posted Apr 06, 2021 - 10:36 EDT
This incident affected: Authentication and Login (Duo (two-factor authentication)).