What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Identity Information Delayed
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Apr 08, 2019 - 11:51 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2019 - 09:50 EDT
Investigating
We are currently investigating an issue where information updates are delayed in and out of identity management. Password changes and resets are still functional. Authentication and single sign on are still functional.
Posted Apr 08, 2019 - 09:02 EDT
This incident affected: Authentication and Login (Brandeis Account Management (identity.brandeis.edu)).