What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Campus Network Service Disruption
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Jun 13, 2019 - 13:15 EDT
Investigating
ITS is aware that there intermittent connectivity to the campus network (wired and wireless). We are investigating the issue and will update this incident as more information becomes available.
Posted Jun 13, 2019 - 11:33 EDT
This incident affected: Network/Internet.