What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

www.brandeis.edu is currently unavailable
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 09:31 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2019 - 08:41 EDT
Investigating
We are currently investigating problems with the public websites such as www.brandeis.edu
Posted Oct 12, 2019 - 08:35 EDT
This incident affected: Brandeis Websites and Applications.