What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Duo Two Factor - Issue with phone call authentication
Incident Report for Brandeis University
Resolved
Duo Security has confirmed that the phone authentication delivery issue has been resolved. They will continue to monitor the system. The new caller ID that you will see for Duo two-factor authentication methods is +1-669-201-9315.
Posted Nov 08, 2019 - 11:03 EST
Investigating
Issue with Delivery of Phone Call Authentications

Duo Security has identified an issue affecting delivery of phone call authentications. They are investigating the issue and are working on resolving the problem. Updates will be posted as they become available.
Posted Nov 07, 2019 - 13:33 EST
This incident affected: Authentication and Login (Authentication/Login).