What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

MarketPlace+ / Coupa Connectivity Issue
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 15:10 EDT
Monitoring
A fix has been implemented for the MarketPlace+/ Coupa connection issue and the vendor is monitoring the issue.
Posted Apr 04, 2024 - 12:16 EDT
Investigating
We are receiving reports of users experiencing issues connecting to MarketPlace+/Coupa. We are actively working with the vendor to address the issue.
Posted Apr 04, 2024 - 09:53 EDT
This incident affected: Other Systems/Services (Marketplace+/Coupa).