What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Inaccessible Sites
Incident Report for Brandeis University
Resolved
Box.com and other Dyn.com customer sites are now up and running - Dyn has resolved the attack that caused the outage.
Posted Oct 24, 2016 - 14:07 EDT
Identified
Some sites such as box.com are intermittently failing to load. The root cause has been identified and more information can be found at https://www.dynstatus.com/incidents/nlr4yrr162t8
Posted Oct 21, 2016 - 12:37 EDT
This incident affected: Collaboration and Sharing (Box Downloads, Box Uploads, Box Sync).