What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Password reset/change unavailable

Incident Report for Brandeis University

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 15:47 EDT

Monitoring

A fix has been implemented and the situation is being monitored. If you continue to experience problems please contact the Technology Help Desk (help@brandeis.edu or 781-736-4357).
Posted Mar 10, 2026 - 07:41 EDT

Investigating

Password change/reset is currently unavailable. ITS is working with the vendor to resolve this issue.
Posted Mar 10, 2026 - 06:56 EDT
This incident affected: Authentication and Login (Brandeis Account Management Systems).