What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Workday - Performance Issues

Incident Report for Brandeis University

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 12:19 EDT

Monitoring

Workday service has been restored. You are now able to login and use the system.
Posted Mar 17, 2025 - 16:31 EDT

Investigating

Workday is experiencing performance issues which may impact logins. They are actively working to identify the root cause and implement a solution, and will be updating us regularly. We will update the community as we get further information.
Posted Mar 17, 2025 - 15:22 EDT
This incident affected: ERP (Workday, sage, Finance, Data Warehouse).