Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.
Our software vendor has confirmed that the issues surrounding access to Tableau Cloud ha been resolved. If anyone continues to have issues connecting, please contact help@brandeis.edu
Posted Mar 18, 2026 - 15:45 EDT
Investigating
There is a performance degradation impacting Tableau Cloud. Tableau engineers are currently working on a solution to resolve user impact. During a performance degradation users can access the Tableau service, but some functionality can be unavailable or running at less than optimal performance. General and intermittent slow performance, timeouts, and connectivity issues are possible. Thank you for your patience.
Posted Mar 18, 2026 - 11:01 EDT
This incident affected: Other Systems/Services (Other Campus Systems/Services).