Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.
Get email notifications whenever Brandeis University creates, updates or resolves an incident.
Get text message notifications whenever Brandeis University creates or resolves an incident.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2025 - 23:00 EDT
Scheduled
TeamDynamix (TDx) will be unavailable on Saturday, Mar. 15 from 11:00 p.m. - 3:00 a.m. TDx will be unavailable for 4 hours so the software can be upgraded to the newest version. Any emails sent to TeamDynamix during the maintenance period will be processed after the maintenance has finished. Please email TDXAdmin@brandeis.edu with any questions.
Posted Mar 13, 2025 - 12:00 EDT
This scheduled maintenance affected: Other Systems/Services (Service Management and Ticketing (TeamDynamix)).