Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.
Get email notifications whenever Brandeis University creates, updates or resolves an incident.
Get text message notifications whenever Brandeis University creates or resolves an incident.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2019 - 06:00 EST
Scheduled
ITS will be performing scheduled maintenance to the campus wireless network during this time. There may be a brief disruption in wireless network connectivity. If you experience any issues with the campus network after the scheduled maintenance, please contact the Help Desk (6-HELP or help@brandeis.edu).
Posted Nov 04, 2019 - 11:58 EST
This scheduled maintenance affected: Network/Internet.