Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.
This problem has been resolved. If you still experience problems validating email addresses or resetting your password using email please contact the Technology Help Desk (781-736-4357 or help@brandeis.edu).
Posted Jul 16, 2026 - 06:27 EDT
Update
We are continuing to investigate this issue.
Posted Jul 14, 2026 - 09:50 EDT
Update
ITS is still investigating, however, gmail.com addresses are currently working. outlook.com and hotmail.com are not. Other third party email addresses may or may not. If the email option does not work please use the cell phone option or contact the Technology Help Desk (781-736-4357 or help@brandeis.edu).
Posted Jul 14, 2026 - 09:49 EDT
Investigating
ITS is currently investigating an issue where password reset links and PINs sent via email are not being delivered. This means using email password reset (and new email address verification) are not currently working. Please use the cell phone option or contact the Technology Help Desk (781-736-4357 or help@brandeis.edu).
Posted Jul 13, 2026 - 07:18 EDT
This incident affected: Authentication and Login (Brandeis Account Management Systems).