What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Workday: Incoming Student Enrollment Checklist Temporarily Unavailable

Incident Report for Brandeis University

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 10:34 EDT

Update

ITS has resolved the issue with the Incoming Student Checklist in Workday. If anyone continues to have issues, please email help@brandeis.edu
Posted Jul 31, 2026 - 10:33 EDT

Investigating

The Incoming Student Enrollment Checklist in Workday is temporarily unavailable. ITS is aware of the issue and actively working to identify the cause.
Posted Jul 30, 2026 - 11:16 EDT
This incident affected: Workday (Workday Student).