What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Student Printing

Incident Report for Brandeis University

Resolved

The issue with student print queues is now resolved. For guidance on setting up printers on your personal device, kindly refer to the instructions provided on this page: https://kb.brandeis.edu/display/LTS/Student+Printing:+Print+from+personal+devices
Posted Sep 12, 2023 - 12:39 EDT

Update

ITS is working to resolve an issue with Windows only devices not finding the correct student print queue. Mac and other iOS devices appear to work as expected.

Students who are impacted by this issue should use the Web Print option to print anything they need until this is resolved. (https://student-print.brandeis.edu:9192/user)

Please reach out to the Help Desk at help@brandeis.edu if you have any questions. Thank you for your patience.
Posted Sep 11, 2023 - 10:20 EDT

Monitoring

ITS has successfully resolved the issue that was impacting printing to both the Brandeis Student B&W and Brandeis Student Color queues. For guidance on setting up printers on your personal device, kindly refer to the instructions provided on this page: https://kb.brandeis.edu/display/LTS/Student+Printing:+Print+from+personal+devices
Posted Sep 07, 2023 - 16:38 EDT

Investigating

ITS has identified an ongoing problem affecting the printing to both the Brandeis Student B&W and Brandeis Student Color queues. While our team is working to resolve this issue, we kindly request that you utilize Web Print through the following link: https://student-print.brandeis.edu:9192/user
Posted Sep 07, 2023 - 14:46 EDT
This incident affected: Other Systems/Services (Campus Printing (Papercut)).