What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Financial Aid Portal - Service restored
Incident Report for Brandeis University
Resolved
ITS has resolved the issue with the Financial Aid Portal (netpartner.brandeis.edu). Access from on and off campus has been restored. If you have any issues accessing the portal, please contact the Help Desk (6-HELP or help@brandeis.edu).
Posted Jan 17, 2020 - 10:45 EST
Monitoring
ITS has resolved the issue with the Financial Aid Portal (netpartner.brandeis.edu). Access from on and off campus has been restored. If you have any issues accessing the portal, please contact the Help Desk (6-HELP or help@brandeis.edu).
Posted Jan 16, 2020 - 20:22 EST
Investigating
ITS is investigating an issue with the Financial Aid Portal (netpartner.brandeis.edu) where students are unable to access the tool from both on or off campus. We are working to resolve the issue and updates will continue to be posted as they become available. We apologize for the inconvenience.
Posted Jan 16, 2020 - 16:13 EST
Identified
ITS has identified an issue with the Financial Aid Portal (netpartner.brandeis.edu) where students are unable to access the tool from off campus. We will be applying a critical update to resolve the issue. Updates will be posted as they become available. If you have any questions or issues after the update, please contact the Help Desk (6-HELP or help@brandeis.edu).
Posted Jan 16, 2020 - 12:26 EST
This incident affected: Other Systems/Services (Miscellaneous Campus Systems/Services).