What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Windows Upgrade Issue
Incident Report for Brandeis University
Resolved
The Windows Upgrade issue has been resolved. (this was reopened because we continue to monitor the issue)
Posted Mar 27, 2024 - 09:39 EDT
Update
ITS is investigating an issue with the Windows Update process that may result in PCs being unexpectedly upgraded to Windows 11
Posted Mar 27, 2024 - 08:45 EDT
Update
We are continuing to investigate this issue.
Posted Mar 26, 2024 - 17:57 EDT
Investigating
ITS is investigating an issue with the Windows Update process that may result in PCs being unexpectedly upgraded to Windows 11
Posted Mar 26, 2024 - 17:56 EDT
This incident affected: Desktop Systems.