What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

help.brandeis.edu emergency maintenance
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 21:27 EDT
Investigating
The help system help.brandeis.edu needs emergency maintenance due to a full disk.
Posted Jul 24, 2020 - 19:53 EDT
This incident affected: Brandeis Websites and Applications and Server Administration (Server Administration).