What is this site?

Information Technology Services will use this page to announce scheduled and unplanned outages. If you wish to be notified, please click the subscribe button and select which services you wish to receives updates for.

Google Mail (GMail) Delayed Delivery
Incident Report for Brandeis University
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 15:08 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2023 - 16:10 EDT
Update
We are continuing to investigate this issue.
Posted Mar 11, 2023 - 11:16 EST
Investigating
ITS is investigating reports of delayed emails -- both inbound and outbound through GMail.
Posted Mar 11, 2023 - 11:13 EST
This incident affected: Email (Google Apps Gmail, Outbound mailing services, Email delivery (sending/receiving)).